Temporary disruption in parts of Heap web app

Incident Report for Heap

Resolved

This incident has been resolved.
Posted Mar 10, 2025 - 02:37 PDT

Monitoring

The fix has been applied and we are monitoring the system.
Posted Mar 10, 2025 - 02:02 PDT

Identified

The issue has been identified.
Posted Mar 10, 2025 - 01:56 PDT

Investigating

We are investigating a performance degradation for some customers in the Heap web app. No data has been lost.
Posted Mar 10, 2025 - 01:53 PDT
This incident affected: App.