Some customers with Session Replay may be experiencing more limited retention in Heap

Incident Report for Heap

Update

The issue has been identified and a fix is being implemented. We are currently working to backfill the data and update customers as soon as possible
Posted Mar 03, 2026 - 08:24 PST

Identified

The issue has been identified and a fix is being implemented. We are currently working to backfill the data and update customers as soon as possible
Posted Mar 03, 2026 - 08:22 PST
This incident affects: Data Collection and App.