Multiple Query Failures in Heap App

Incident Report for Heap

Resolved

This incident has been resolved.
Posted Jun 26, 2025 - 16:10 PDT

Monitoring

The fix has been implemented. We are monitoring.
Posted Jun 26, 2025 - 15:55 PDT

Update

Functionality is actively being restored, but some customers will still experience query failures at this time.
Posted Jun 26, 2025 - 15:51 PDT

Update

We are continuing to work on a fix for this issue.
Posted Jun 26, 2025 - 15:12 PDT

Update

we are continuing to work on this issue.
Posted Jun 26, 2025 - 14:28 PDT

Identified

We have identified the problem and are working on implementing a fix.
Posted Jun 26, 2025 - 12:52 PDT

Investigating

We are currently investigating query failures across multiple clusters in the Heap App. Data collection is not affected and no data has been lost.
Posted Jun 26, 2025 - 12:14 PDT
This incident affected: App.