US connect customers: possibility of stale data

Incident Report for Heap

Resolved

This incident has been resolved
Posted Aug 11, 2026 - 23:39 PDT

Monitoring

Latency is recovered, we continue to monitor. Your data will automatically catch up during the next regularly scheduled sync.
Posted Aug 11, 2026 - 22:47 PDT

Identified

We are experiencing latency in data getting to connect syncs. Any syncs running during this time may get stale data.
Posted Aug 11, 2026 - 21:35 PDT
This incident affected: Heap Connect.