Plan Selection Page Unavailable
Incident Report for Heap
Resolved
This incident has been resolved.
Posted Feb 24, 2021 - 17:25 PST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Feb 24, 2021 - 15:06 PST
Identified
Our plan selection page is currently unavailable. This primarily affects users at the end of their free trial. We've identified the issue and are in the process of implementing a fix.
Posted Feb 24, 2021 - 12:46 PST
This incident affected: App.