Customers with multiple environments or saved properties are experiencing loading latency

Incident Report for Heap

Resolved

This incident has been resolved
Posted Jun 17, 2026 - 23:58 PDT

Investigating

We are currently investigating this issue.
Posted Jun 17, 2026 - 07:45 PDT
This incident affected: App.