Slow queries
Incident Report for Heap
Resolved
This incident has been resolved.
Posted Nov 09, 2017 - 14:08 PST
Update
All clear!
Posted Nov 09, 2017 - 14:07 PST
Investigating
Some dashboard queries are taking longer than expected. Our engineering team is investigating.
Posted Nov 09, 2017 - 13:45 PST