Heap Data Collection Incident

Incident Report for Heap

Resolved

The data has been reloaded and this incident is resolved.
Posted Jul 14, 2025 - 15:13 PDT

Update

The data reload is in progress. We will post an update when it is complete.
Posted Jul 11, 2025 - 10:12 PDT

Update

The data reload is in progress. We will post an update when it is complete.
Posted Jul 11, 2025 - 10:09 PDT

Monitoring

We have identified and mitigated this issue. Data ingestion has been fully restored.
The data not ingested during this incident will be reloaded and we will post an update when this reload is complete.
Posted Jul 09, 2025 - 18:07 PDT

Update

We are continuing to investigate this issue.
Posted Jul 09, 2025 - 17:49 PDT

Investigating

We are currently investigating an incident that is impacting data collection for all Heap customers. We will post an update within an hour.
Posted Jul 09, 2025 - 17:32 PDT
This incident affected: Data Collection.