Some customers experiencing latency

Incident Report for Heap

Resolved

This incident has been resolved.
Posted Nov 19, 2025 - 20:30 PST

Monitoring

All systems are now working and we are actively monitoring
Posted Nov 19, 2025 - 12:51 PST

Update

Some customers experiencing query latency. Queries for some customers may take a while to load or return errors. Data collection is not impacted.
Posted Nov 19, 2025 - 09:06 PST

Investigating

We are currently investigating this issue.
Posted Nov 19, 2025 - 09:04 PST
This incident affected: App.