Heap Connect Syncs: Possibility Of Stale Data

Incident Report for Heap

Update

We are continuing to work on a fix for this issue.
Posted Aug 15, 2026 - 09:26 PDT

Identified

We are experiencing latency in our upstream data source. Syncs running during this period may have stale data. We will post an update in 2 hours.
Posted Aug 15, 2026 - 07:32 PDT
This incident affects: Heap Connect.