Truncated Shopify data
Incident Report for Heap
Resolved
Restoration of truncated Shopify event properties is being handled in the scheduled maintenance.
Posted Apr 08, 2020 - 20:13 PDT
Update
We will be restoring Shopify events between 6PM and 9PM Pacific, and will update with more details when the restore is complete.
Posted Apr 08, 2020 - 16:02 PDT
Update
We have confirmed that Shopify events ingested after 11AM Pacific, April 8 2020 are correct.

Some properties for Shopify events ingested between April 1 and April 8 may currently be clipped to 1024 characters (truncated) in the Analysis interface.

We will post details about our timeline for restoring truncated Shopify data before 6PM Pacific.
Posted Apr 08, 2020 - 11:28 PDT
Update
We are continuing to investigate truncated Shopify data and will post an update within an hour.
Posted Apr 08, 2020 - 11:16 PDT
Identified
We have identified an issue where some events from our Shopify integration may have been truncated since April 1.

We are pausing further ingestion of Shopify data while we work on mitigations, and will post an update within an hour.
Posted Apr 08, 2020 - 10:12 PDT
This incident affected: Data Collection.