Slow Queries

Incident Report for Heap

Resolved

This incident has been resolved.
Posted Jul 02, 2026 - 09:50 PDT

Monitoring

Queries have resumed. We are monitoring.
Posted Jul 02, 2026 - 09:40 PDT

Investigating

We are current investigating an issue with slow/unresponsive queries for a subset of customers. No data is lost. We will post an update in 2 hours.
Posted Jul 02, 2026 - 09:30 PDT
This incident affected: App.