Incoming data is delayed for customers in US. Both the Heap app and Connect are impacted.

Incident Report for Heap

Resolved

Latency has recovered for all components. No data was lost.
Connect syncs will sync the latest data on the next regularly scheduled sync.
We will continue to monitor.
Posted Jun 20, 2026 - 17:36 PDT

Update

Latency has recovered for the App. Latency is still recovering for Connect syncs. We continue to monitor.
Posted Jun 20, 2026 - 17:10 PDT

Update

Latency has recovered for the App. Latency is still recovering for Connect syncs. We continue to monitor.
Posted Jun 20, 2026 - 16:03 PDT

Monitoring

The fix has been applied and latency is recovering. We continue to monitor.
Posted Jun 20, 2026 - 14:22 PDT

Update

We continue to work on a fix for this issue. We will post an update as soon as one is available.
Posted Jun 20, 2026 - 13:54 PDT

Update

We are continuing to work on the fix for this issue.
Posted Jun 20, 2026 - 11:59 PDT

Update

We continue to work on a fix for this issue
Posted Jun 20, 2026 - 11:06 PDT

Identified

No data has been lost. We are working on a fix
Posted Jun 20, 2026 - 10:10 PDT
This incident affected: App, Heap Connect, and Integrations - Destinations.