Temporary Data Latency - Investigating

Incident Report for Heap

Monitoring

Latency is resolving. We are currently monitoring.
Posted Jul 27, 2026 - 12:45 PDT

Update

We are continuing to investigate the issue
Posted Jul 27, 2026 - 12:09 PDT

Investigating

We are currently experiencing delays in data being available in the app for a subset of customers. You may notice missing data in your reports. Data collection is unaffected, and no data has been lost. Our engineers are currently investigating the issue.
Posted Jul 27, 2026 - 11:12 PDT
This incident affects: Data Collection and App.