Email reports, password resets, and invite emails are temporarily unavailable
Incident Report for Heap
Resolved
Email reports, invites and passwords resets have resumed regular functionality. Thank you for your patience.
Posted 18 days ago. Jul 03, 2019 - 12:37 PDT
Investigating
We are currently experiencing some issues with email reports, invites and password resets. Please email support@heapanalytics.com for help with these procedures.
Posted 18 days ago. Jul 03, 2019 - 11:04 PDT
This incident affected: App.