Heap Connect Sync Delays

Incident Report for Heap

Resolved

This incident has been resolved.
Posted Oct 11, 2025 - 01:55 PDT

Monitoring

A fix has been applied, and impacted connect syncs are recovering. Upcoming syncs will be processed on their usual schedule. We continue to monitor during this recovery period.
Posted Oct 10, 2025 - 14:17 PDT

Update

We continue to work on a fix for this issue.
Posted Oct 10, 2025 - 11:43 PDT

Update

We are continuing to work on a fix for this issue
Posted Oct 10, 2025 - 09:50 PDT

Identified

Our engineering team has identified the root cause of the delayed syncs and is working on a solution.

Data is still being collected and no data has been lost.

We will post an update in one hour.
Posted Oct 10, 2025 - 08:28 PDT
This incident affected: Heap Connect.