Web SDK Serve Latency
Incident Report for Heap
Resolved
This incident has been resolved. During the incident period (12:03 PM PT - 1:34 PM PT), Heap may have failed to collect clicks which occurred within the first 7 seconds after a page loads. Pageviews, sessions, subsequent clicks and client-side API calls were unaffected. We apologize deeply for any effect this has had on our customers.
Posted Nov 28, 2022 - 15:37 PST
Monitoring
We scaled out a backing database and this resolved the incident. We are monitoring the stability of the platform currently.
Posted Nov 28, 2022 - 13:43 PST
Update
We are currently scaling up a backing database. During this time, the app may be momentarily unavailable.
Posted Nov 28, 2022 - 13:25 PST
Update
We are continuing to investigate the issue.
Posted Nov 28, 2022 - 13:00 PST
Investigating
We are currently investigating an issue where the Heap web SDK may be slow to load on customers' sites. This should not impact the performance of your web page. Our engineers are currently investigating the issue. We'll be posting another update in 30 mins.
Posted Nov 28, 2022 - 12:28 PST
This incident affected: Data Collection.