User property data delayed in Heap app (US customers only)

Incident Report for Heap

Resolved

Latency has recovered to normal levels.
Posted Jul 16, 2025 - 16:00 PDT

Update

Latency continues to recover and we are monitoring.
Posted Jul 16, 2025 - 14:43 PDT

Monitoring

User property data ingestion was delayed beginning around 10am Pacific Time. Normal ingestion has since resumed and latency is recovering. We will post an update within the hour.
Posted Jul 16, 2025 - 13:37 PDT
This incident affected: Data Collection.