Third party integration events latency impacting some customers

Incident Report for Heap

Resolved

This incident has been resolved
Posted Sep 23, 2026 - 07:35 PDT

Update

We are continuing to work on a fix for this issue.
Posted Sep 22, 2026 - 19:54 PDT

Identified

We have identified an issue where users may see delays in 3rd party integration events getting to the app, and potentially split users.
Posted Sep 22, 2026 - 15:43 PDT
This incident affected: App and Integrations - Sources.