Heap Connect Syncs: Possibility Of Stale Data (EU Only)

Incident Report for Heap

Resolved

This incident has been resolved.
Posted Mar 30, 2026 - 11:05 PDT

Monitoring

A fix has been applied and latency is beginning to recover
Posted Mar 30, 2026 - 10:21 PDT

Identified

We are experiencing latency in our upstream data source. Syncs running during this period in the EU may have stale data. We will post an update within the hour.
Posted Mar 30, 2026 - 07:30 PDT
This incident affected: Heap Connect.