Connect Sync Delays

Incident Report for Heap

Resolved

This incident has been resolved
Posted Jul 26, 2026 - 10:06 PDT

Identified

Some US customers using HFT syncs may experience delays in data processing or availability. The issue has been identified, and our teams are working on a resolution.
Posted Jul 26, 2026 - 07:06 PDT
This incident affected: Heap Connect.