Latency in integration events impacting PA customers

Incident Report for Heap

Resolved

This incident has been resolved.
Posted Aug 25, 2025 - 17:53 PDT

Monitoring

A fix has been implemented and we are monitoring latency as it begins to recover.
Posted Aug 25, 2025 - 17:14 PDT

Identified

We are rolling out a fix for the latency that is currently impacting integration events.
New events from third-party sources may take longer to appear in Heap at this time. No data has been lost.
Posted Aug 25, 2025 - 16:45 PDT
This incident affected: Integrations - Sources.