Partial service disruption for some Heap/PA customers

Incident Report for Heap

Update

We are continuing with this investigation. We will post an update as soon as one is available.
Posted Mar 15, 2026 - 12:54 PDT

Update

We continue to investigate this issue.
Posted Mar 15, 2026 - 11:58 PDT

Update

We are continuing to investigate this issue.
Posted Mar 15, 2026 - 10:30 PDT

Investigating

Some of our customers will see stale data in the app, and may experience queries timing out or failing. We are currently investigating.
Data continues to be collected and no data has been lost. We will post an update within an hour.
Posted Mar 15, 2026 - 09:43 PDT
This incident affects: App.