This issue is now resolved. React native screen view events are now fully functional in the Heap UI. There has been no data loss to any events.
Posted May 17, 2024 - 18:18 PDT
Monitoring
Heap has implemented a solution to address the issue with React Native screenview-defined events and are currently monitoring its performance to ensure everything is working smoothly.
Posted May 17, 2024 - 15:22 PDT
Investigating
Heap is continuing to investigate the issue regarding react navigation screen view defined events not appearing in the Heap UI. There is no data loss and all other events can be used for analytical purposes. We apologize for the inconvenience.
Posted May 17, 2024 - 06:28 PDT
Identified
Currently, React Native screen view events cannot be utilized within the Heap UI. All other types of events can still be used safely in the Heap UI. This current limitation does not result in any data loss and all events are still being captured and stored for analytical purposes. Heap apologizes for the inconvenience.