Heap Connect Syncs: Possibility Of Stale Data (US)

Incident Report for Heap

Resolved

This incident has been resolved. Latency has recovered at this time.
Posted Aug 29, 2025 - 10:11 PDT

Monitoring

Latency has recovered at this time. We continue to monitor.
Posted Aug 28, 2025 - 13:29 PDT

Update

We are experiencing latency from upstream data lake ingestion. This will cause Connect to sync stale data during this period of latency. We will post an update here when latency is resolved. Reach out to support if help is required.
Posted Aug 28, 2025 - 10:48 PDT

Identified

We are experiencing latency in our upstream data source. Syncs running during this period may have stale data. We will post an update within the hour.
Posted Aug 28, 2025 - 09:43 PDT
This incident affected: Heap Connect.