Elevated app load times
Incident Report for Heap
Resolved
This incident is resolved.
Posted Mar 17, 2020 - 10:04 PDT
Investigating
The Heap app is currently experiencing elevated load times. Our engineers are investigating.
Posted Mar 17, 2020 - 08:46 PDT
This incident affected: App.