EU Temporary Data Latency

Incident Report for Heap

Resolved

This incident has been resolved
Posted Sep 19, 2025 - 08:09 PDT

Update

We are actively working on a fix for this issue.
Posted Sep 19, 2025 - 07:31 PDT

Identified

Our engineering team has identified the root cause of the delayed ingestion and is working on a solution.

Users will see delays in data appearing in the app, and the data synced in Connect during this period will be stale.

Data collection is unaffected, and no data has been lost.
Posted Sep 19, 2025 - 06:42 PDT
This incident affected: App and Heap Connect.