Some users unable to login

Incident Report for Heap

Resolved

This has been resolved
Posted Jul 14, 2025 - 11:26 PDT

Investigating

We are currently investigating this issue.
Posted Jul 14, 2025 - 11:18 PDT
This incident affected: App.